Call Us Toll-Free: (800) 584-8859

System Requirements

The following browsers and operating systems meet security and application requirements for Peoples Online.

Operating System Microsoft Internet Explorer Apple Safari® Mozilla Firefox Google Chrome™
Note: Cookies and Javascript must be enabled
Windows Vista® 9.0 4.0, 5.0 39.0, 40.0 44.0, 45.0
Windows 7 10.0, 11.0 N/A 39.0, 40.0 44.0, 45.0
Windows 8 10.0 N/A 39.0, 40.0 44.0, 45.0
Windows 8.1 11.00 N/A 39.0, 40.0 44.0, 45.0
Windows 10 Edge, 11.0 N/A   44.0, 45.0
Mac OS X 10.9 (Mavericks™) N/A 7.0 39.0, 40.0 N/A
Mac OS X 10.10 (Yosemite™) N/A 8.0 39.0, 40.0 N/A
iPad® N/A 7.1 N/A N/A
iPad® mini N/A 7.1 N/A N/A

For maximum security, always use the latest version of a browser. Beta versions of browsers and operating systems are not recommended or supported. Additionally, if a browser or operating system is no longer supported by the vendor, it is not supported by Peoples Online.

Other browsers and operating systems may be used; however, they are not supported by the system and some features may not function properly.

Last updated on 9/22/2015

Enroll in Online Banking

Manage your account anytime anywhere.

Get Started